Problem using delegated identity

Ahmad Gharbeia gharbeia at gmail.com
Thu Jan 22 19:15:30 UTC 2009


Thank you, Chris for your response. I didn't know this is not the right
place. I tried the IRC channel #openid at freenode but it's deserted.

رسالة user-experience-request at openid.net في 22/01/09 18:58:
> Message: 2
> Date: Wed, 21 Jan 2009 17:47:31 -0800
> From: Chris Messina <chris.messina at gmail.com>
> Subject: Re: Problem using delegated identity
> To: OpenID user experience <user-experience at openid.net>
> Message-ID:
> 	<1bc4603e0901211747k76beec2ax541ee182c09f4a8 at mail.gmail.com>
> Content-Type: text/plain; charset="iso-8859-1"
> 
> I'm not sure this is the best place for this kind of discussion, but we can
> certainly work through it see what we come up with.
> It does look like the sites you mentioned are using Janrain's RPX service:
> 
> http://rpxnow.com
> 
> Your delegation looks okay for the most part. I'm unclear whether RPX is
> prioritizing the <link />-based delegation or directing grabbing your XRDS
> profile.

I thought along the same line, so before I wrote here, I had tried
modifying the XRDS file as well removing references to v2.0 delegates,
and switching between several of them.


> In either case, it looks like you have a duplicate tag for the
> X-XRDS-Location. Try removing these tags:
> 
> <meta http-equiv="X-XRDS-Location" content="http://ahmad.gharbeia.org/xrds"
> />
> 
> <meta http-equiv="X-Yadis-Location" content="http://ahmad.gharbeia.org/xrds"
> />
> You already specified this earlier in the document:
> 
> 
> <meta http-equiv="X-XRDS-Location" content="
> http://ahmad.gharbeia.org/yadis.xrds" />
> 
> 
> and the later URLs seem to return an empty document.

I'm aware of this. It seems to be a Drupal issue. If the consumer is
designed to honour the latest mentioned announcement, then this may be a
problem. I'll try to solve this, either at its source, or by a work
around through redirecting the bogus announcement to the real.

Thanks again,
Ahmad





More information about the user-experience mailing list