[Openid-specs-ab] is part of rp test site unavailable?

Filip panva.ip at gmail.com
Sun Dec 4 11:43:11 UTC 2016


I believe i was able to reproduce the issue a while back.

At the time I didn't want to explore it any further, as having the service
up and running and being able to develop a test suite, providing feedback
to the scenarios, was far more important.

Here are the steps i noted down at the time:

1) visit an RP log folder (i.e. https://rp.certification.openid.net:8080/
log/node-openid-client)
2) click clear (got 200 OK from and landed on https://rp.certification.
openid.net:8080/clear/node-openid-client)
3) hit F5 (got 500 Server Error)
4) service hangs

This exact case may already be fixed, but since there is no automated
recurring check, that would restart the service, i'm avoiding testing it :)
Instead, the test suite navigates the to log folder first, to see if clear
/ download is available, and then executes the clear/download
<https://github.com/panva/openid-client-conformance-tests/blob/799214ee6b591937b4161fd63104a5a8bb5d111f/test/helper.js#L23-L52>
.

Best,
*Filip Skokan*

On Fri, Dec 2, 2016 at 11:32 PM, rich levinson via Openid-specs-ab <
openid-specs-ab at lists.openid.net> wrote:

> Hi Roland,
>
> Thanks, I was able to access the site, BUT,
> when I got there it presented a msg that the log was empty.
>
> Then I cut back the URL to:
>   https://rp.certification.openid.net:8080/log/
>
> where, if I recall correctly, there were a couple navigation links,
> which I followed and after a couple of clicks got to:
>    https://rp.certification.openid.net:8080/log//node-openid-client
>
> which I think is where I was there several days ago, which has a list
> of test results, which is what I was looking for.
>
> However, I first tried to download the tar file, which is a link at the
> bottom
> of the above page, and it didn't seem to like that at all, can't remember
> the
> exact messages, but went "back" to the list page, and tried to download
> just a single file from one of the links in the list, and got an error on
> chrome
> about fixing file downloads.
> On IE, when I try to access the following:
>     https://rp.certification.openid.net:8080/
>
> I get a message:
>
> "This page can’t be displayed
>
> Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings
>  and try connecting to https://rp.certification.openid.net:8080  again.
> If this error persists, it is possible that this site uses
>  an unsupported protocol or cipher suite such as RC4 (link for the details),
>  which is not considered secure. Please contact your site administrator.
>
> Change settings"
>
> I clicked on the change settings button, and my
>   TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings
> were already turned on.
>
> Any indication on the server of any problems?
> My time of connect was approx 5PM est, 2PM pst.
>
>   Thanks,
>   Rich
>
>
>
>
> On 12/2/2016 9:40 AM, Roland Hedberg wrote:
>
> 2 dec. 2016 kl. 00:16 skrev rich levinson via Openid-specs-ab <openid-specs-ab at lists.openid.net> <openid-specs-ab at lists.openid.net>:
>
> On the "Conformance Testing for RPs" page:
>   http://openid.net/certification/rp_testing/
>
> near the end of the page, there is a link to
> "An actual example of such a set of test logs is":
>     https://rp.certification.openid.net:8080/log/mod_auth_openidc
>
> it times out when I try to access it w the following info:
> "rp.certification.openid.net took too long to respond.
> Try:
> Checking the connection
> Checking the proxy and the firewall
> Running Windows Network Diagnostics
> ERR_TIMED_OUT"
> I have accessed it before, successfully, but I have been unable to
> for the last couple of days. I tried both from my corporate laptop,
> and my own personal system, which does not use the corp network.
> and both fail the same way.
>
> Any suggestions?
>
>
> I’ve restarted the service.
>
> -- Roland
> "Education is the path from cocky ignorance to miserable uncertainty.” - Mark Twain
>
>
>
>
>
>
> _______________________________________________
> Openid-specs-ab mailing list
> Openid-specs-ab at lists.openid.net
> http://lists.openid.net/mailman/listinfo/openid-specs-ab
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openid.net/pipermail/openid-specs-ab/attachments/20161204/c3d69ed3/attachment.html>


More information about the Openid-specs-ab mailing list