[Openid-specs-ab] FW: [openid/connect] Rename "OpenID Request Object" to "Request Object" (issue #788)
Michael.Jones at microsoft.com
Mon Mar 4 05:38:29 UTC 2013
I believe we change to the name of the OpenID Request Object to no longer include "OpenID", since it could actually be used for any OAuth Request.
From: Michael Jones [mailto:issues-reply at bitbucket.org]
Sent: Sunday, March 03, 2013 9:25 PM
To: Mike Jones
Subject: [openid/connect] Rename "OpenID Request Object" to "Request Object" (issue #788)
--- you can reply above this line ---
New issue 788: Rename "OpenID Request Object" to "Request Object"
The data structure we call an "OpenID Request Object" actually has nothing OpenID-specific about it anymore. It can be used as a generic way of sending request parameters to OAuth. Thus, I think we should rename it to simply "Request Object", as this may facilitate our IANA registration of the "request" and "request_uri" parameters, when the time comes to do that.
Indeed, this is already the terminology used in http://tools.ietf.org/html/draft-sakimura-oauth-requrl-03#section-2.
The only normative change that this will cause is renaming the error parameter "invalid_openid_request_object" to "invalid_request_object".
This is an issue notification from bitbucket.org. You are receiving this either because you are the owner of the issue, or you are following the issue.
More information about the Openid-specs-ab