[Openid-specs-ab] Issue #185: Trouble running any test on my OP (openid/certification)

Benjamin Goering issues-reply at bitbucket.org
Thu Nov 5 22:05:53 UTC 2015


New issue 185: Trouble running any test on my OP
https://bitbucket.org/openid/certification/issues/185/trouble-running-any-test-on-my-op

Benjamin Goering:

Hello, I hope this is the right place to ask for help.

I am developing an OIDC OP for my employer. It is unlikely to be conformant right now, but I'd love to use the self-certification tool to know where to improve.

The issuer I'd like to test it https://accounts.qa-ext.livefyre.com/

Every time I run any test, I get

```
#!

[-]
	status: WARNING
	info: Invalid URL u'/authorize/.well-known/openid-configuration': No schema supplied. Perhaps you meant http:///authorize/.well-known/openid-configuration?
Trace output


0.000306 ------------ DiscoveryRequest ------------
0.000320 Provider info discover from '/authorize'
0.000326 --> URL: /authorize/.well-known/openid-configuration
0.001405 [ERROR] MissingSchema:Invalid URL u'/authorize/.well-known/openid-configuration': No schema supplied. Perhaps you meant http:///authorize/.well-known/openid-configuration?


```

I can't find anywhere in my source code (uses pyoidc) that mentions '/authorize'
My configuration document is here: https://accounts.qa-ext.livefyre.com/.well-known/openid-configuration
https://op.certification.openid.net:60133/test_info/OP-Discovery-Config

Any suggestions? Thank you




More information about the Openid-specs-ab mailing list